LED of your Home Network Security Station has no light

  • Solution ID: 1116156
  • Last Updated: Nov. 13, 2017 8:26 PM (PST)
  • Applies to: Home Network Security - 1.0, 1.1;
  • LED of the Station has no light | Home Network Security

This article shows you what to do if the LED of your Home Network Security Station has no light.


To resolve this issue, check the condition of your Station. Do the following:

Check the physical components of your Station

Check the following components and make sure they are intact:

Make sure you have stable internet connection

To check your internet connection, do the following:

  1. Remove your Home Network Security from the network.
  2. Connect the WAN port to the internet line.
    1. If there is no internect connection, do the following:
      • Reboot your router
      • Check the network status from your Internet Service Provider
      • Check your router settings
    2. If you are able to connect to the internet, reconnect your Home Network Security Station to the router.
Make sure there is power supplied to the Station

To check if the Station has power supply, do the following:

  1. Connect the adapter to the outlet and the Station.
  2. Make sure power on the outlet is turned on.
  3. Change outlets to ensure power is on.
Check your router to Station connection

To check the connection, do the following:

  1. Make sure to connect your Station and the router LAN port using the provided Ethernet cable.
  2. Check the two LED lights of the LAN port.
    • One port should be blinking green
    • The other port should be steady green or yellow
  3. If the LED lights are not normal, move the Ethernet cable to another router LAN port.
    Once the LED lights become normal, your Home Network Security Station condition is normal.

If the issue persists, contact Trend Micro Support for assistance.