System Requirements for Password Manager

  • Solution ID:1111725
  • Last Updated:Nov. 07, 2018 12:51 AM (PST)
  • Applies to:Password Manager - 3.5, 3.7;
  • System Requirements | Password Manager

This article lists the minimum system requirements needed to install and use Password Manager.


For Windows™ PC
Operating System

Windows 10 (32-Bit or 64-Bit)

Windows 8.1 with KB2999226 (32 bit or 64 bit)

Windows 7 SP1 with KB2999226 (32 bit or 64 bit)

Processor 1 Ghz or faster
RAM > 2GB
Disk Space > 300 MB
Supported Web Browsers

Internet Explorer version 11.0

Google Chrome™ (The newest version and the most recent previous version)

Mozilla® Firefox® (The newest version and the most recent previous version)


For Apple® Macintosh®
Operating System

macOS Mojave (version 10.14)

macOS High Sierra (version 10.13)

Processor Intel Core 2 Duo
2.0 GHz or faster
RAM > 2GB
Disk Space > 300 MB
Supported Web Browsers

Safari version 11.0/12.0

Google Chrome™ (The newest version and the most recent previous version)

Mozilla® Firefox® (The newest version and the most recent previous version)


For Mobile Devices
Operating SystemVersion
Android 5.0/5.1/6.0/7.0/7.1/8.0/8.1/9.0
iOS 11.0/11.1/11.2/11.3/11.4/12.0